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Introduction
@depth software, developed by Dutch company Dimenco, is introduced to make high quality 3D
content creation simple. Based on Philips and Dolby technology, Dimenco has integrated unique
algorithms to offer cost-effective (semi-automatic) and high-quality offline conversion of existing 2D
video content and editing of existing 3D Stereo content.
By listening and reaching out to our customers via dedicated content specialists within our company
we strive to continuously improve our software and make this available to our customers via regular
updates.
If you have any suggestions, remarks or special wishes, please contact us to improve our software as
you would like to use it; conversions@dimenco.eu

@Depth Changelog
Version 2.0.2:





Fix: @depth could only use 2GB of memory which sometimes caused crashes or an ‘Out of
Memory’ error.
Fix: you could not enter a ‘1’ when entering a number to show only every Nth frame in the
timeline.
Fix: Cancelling 2D Propagate Accurate did not work correctly.
DMCS: checking ftp for order status/list is faster.

Version 2.0.1:






Fix: The Accurate algorithms could show an error that SVD is needed.
Fix: Settings button in Shot Render Settings window was partly obscured when the vertical
scrollbar was visible.
UI change: When using scrollwheel in timeline, pressing Shift/Ctrl doesn’t change the
selected frame (this makes scrolling much faster)
UI change: selecting multiple frames is possible by holding Shift or Ctrl while clicking (note:
hold either shift/ctrl while using scrollwheel, else selection will be removed)
UI change: by pressing the Keyframe button/menuitem all selected frames will be set/unset
as keyframe. (powerful when first showing every Nth frame in timeline and then marking the
shown frames to keyframes)

Version 2.0.0:





Added a Depth Map Creation Service (DMCS) to send keyframes to Dimenco to be converted
to depthmaps. The created depthmaps can be imported and used for rendering within
@depth. (no documentation included yet!)
Added 2D Propagation Accurate and Stereo Accurate algorithms for rendering.
(no documentation included yet!)
Fix: Progress bar when rendering was not accurate and sometimes decreasing.
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Tweak: a bit better speed performance of the algorithms

Version 1.0.9.1:








Propagate algorithms didn’t preserve original annotated depth (were scaled)
Dragging the timeline scrollbar is now much faster
Support for Quicktime movies when correct DirectShow codecs are installed
Fixed showing/hiding the stereo algorithms when switching/creating projects
Changed color coding for keyframes/shotcuts that need to be updated
(it was not clear what shots need to be updated when showing only keyframes/shotcuts on
the timeline)
Changed startup sequence of @depth to show welcome screen earlier.

Version 1.0.8:





Faster scrolling through timeline.
Fixed an out of memory error when importing image sequences (especially .tga images).
Better error message when a keyframe doesn’t have a valid depthmap yet.
Fixed issue during rendering where pressing Cancel sometimes generated an error message.

Version 1.0.0.7:


Fixed a problem where on some computers @depth would stop with an
ArgumentOutOfRange error when opening or creating a project.
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About this manual
Documentation structure
Within the manual you can find the following information on @depth:
Installation
The user can find detailed information about the system requirements, installation steps and deinstallation procedures.
Working with @depth
After reading this chapter the user understands the @depth GUI and all functionalities. The user
understands the workflow of @depth and is for example able to open projects, working with the
@depth timeline, understands shot cuts and key frames and is able to finalize the project.
The section Shot Settings provides the user advanced background information to provide the best
quality. Especially certain scenes may be more challenging than others, this section describes ways to
solve this.
Troubleshooting
Shows common problems and their solutions.
List of Shortcuts
The user is given an overview of the various keyboard shortcuts that can be used instead of selecting
commands or clicking buttons.
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Terminology and conventions
This manual aims at users who have some experience in working with images and videos. However, to
avoid misunderstandings, consider the following list of @depth terminology which explains the usage
of key terms in the context of the program:
Term

Explanation

Timeline

Timeline is the term used for the lower part of the @depth GUI window. It
displays the frames of your input video and is used to navigate through the
frames, to mark shot cuts and key frames.

Annotation

Annotation means adding depth information to the selected frame with the help
of an image editor such as Photoshop or Paint.

Render!

Render! is the program's term for generating depth for a definable number of
frames.

Key Frame

This is a marker you can set on those frames that need annotation. Together with
another key frame or a shot cut, a key frame forms the boundary to a range.

Shot Cut

This is the first frame in a shot. Together with a key frame it marks the boundary
of a range; together with another shot cut it marks the boundary of a shot.

Shot

A shot represents a frame sequence with only little changes in camera angle and
image content. The first frame of a shot is a shot cut.

Annotated Depth

The annotated depth refers to the user created depth information during
annotation. It is represented by the middle thumbnail image in the respective
Timeline frame.

Generated Depth

The generated depth refers to the depth information @depth has automatically
generated while Rendering. It is represented by the bottom thumbnail image in
the respective Timeline frame.

Default

When loaded into @depth, each input file receives a default depth map. This is
important for the export of a video/image sequence to which you have not
assigned depth.

Depth Map

Additionally, the default depth map is helpful when annotating a frame: it is put
on the clipboard and can then be copied into the image editor.
The size of the default depth map is defined by the current working resolution;
it's grey shade corresponds to the default depth defined when opening the
project (Project > New… > Advanced tab).
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This manual uses the following writing conventions:


Specially marked info boxes contain additional information on the program's processes and
the consequences of specific settings.



References to menu entries, buttons, commands, window text etc. are in bold font, e.g.:
"Choose the command New… from the menu Project to start a new project."



The symbol > is used to connect a chain of commands and menu names, as e.g.:
"Choose the menu command Project > New… to start a new project."



The program's main functions and commands are available as buttons, as menu entries and
as right-click menu entries. To maintain readability, not all of these options are described in
detail for all processes, alternatives are only pointed out.
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Installation
System requirements
Before you start the installation of @depth make sure that your system fulfills all requirements for a
smooth operation.
Hardware
We recommend the following hardware to be used for installation of @depth.
Microsoft Windows compatible PC
Processor:
Dual-Core i5 or higher
RAM:
Minimum 4GB, recommended: 8GB
HDD:
Minimum of 5 GB
Video card:

NVIDIA – Geforce
NVIDIA – Quadro
ATI – Radeon X1650 (tested on Windows XP only)

Recommended:
Dimenco or Philips 3D auto-stereoscopic displays to preview 3D.
All Dimenco 3D displays are supported.
For older Philips 3D displays (before 2010) the 3D Display Firmware Version must be 1.0 B7 or above.
Software
Windows XP (SP3), Windows VISTA or Windows 7 (preferred)
Various Audio and Video Codecs, depending on your input material
Recommended: Windows Media Player 11 or later
Recommended: image editor with layer support, e.g. Adobe Photoshop, GIMP
License
@depth requires a license. On the first start-up, @depth will ask for a license key and gives a
hardware fingerprint. The hardware fingerprint has to be emailed to the @depth service
department. After the email has been processed, a license key will be emailed.
However, the preferred way of obtaining @depth and a license is via our website and is described in
the following section.
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Setup and Installation
It is necessary to submit your Hardware Fingerprint code during the registration.
See below a small guide how to get your Hardware Fingerprint;
1. First download the @depth Hardware Fingerprint Tool from www.dimenco.eu/adepth
2. Extract the zip-file to your desired location
3. Doubleclick on the @depth_hardwarefingerprint.exe

4. In case you get this window. Click Run

5. A new window will pop on your screen. On your keyboard: Hold CTRL + C to copy the Hardware
Fingerprint.

6. Go to the registration page, Complete the registration form. Paste (CTRL+V) your Hardware
Fingerprint at the section Hardware Fingerprint.
If all fields are completed, click Submit at the bottom.
7. After completing the form, we will manually process your request.
8. Within 2 working days, you will receive a 30-day trial key + the download link for @depth
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9. Start the setup by double-clicking the file setup.exe. The missing software components window
opens:

Click Install to accept the installation of the missing software components. The installation
process is started, and its progress is visualized by progress bars.
After the installation process the ‘Welcome to the Dimenco @depth Setup Wizard’ opens

10. To Proceed click ‘Next’
11. Click ‘Next’ if you agree with the folder where you like to install the @depth software.
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12. Read the @depth software terms and conditions and select ‘I Agree’ if you agree with the terms
and conditions. If you select ‘I do not Agree’ the installation will be cancelled.

13. Click ‘Next’ to continue with the installation.
14. The @depth software is now being installed and its progress is visualized by progress bars. This
can take a few minutes.
15. @depth is now successfully installed. Click ‘Close’ to close the installation window.
16. The @depth software can now be used and started.
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De-installation
If you would like to de-install the software, please use the following steps. Note that this will not
remove the license for @depth from the computer.
Windows Vista/7
To remove @depth or to restore a former version of the software, open the Windows Vista start
menu, go to Control Panel > Uninstall a program and choose @depth from the program list.
Windows XP
Under Windows XP, open the Windows start menu and use the respective functionality in Control
Panel > Add or Remove Programs.
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Working with @depth
Introduction
With @depth, you can post process your 2D videos semi-automatically, generate automatically depth
information to stereo videos, or further enhance 3D computer graphics content. It supports
transparency information on most input files.
For annotation – i.e. for adding depth information to a 2D frame – a default greyscale depth map is
copied to the clipboard and can be pasted into the image editor that opens automatically. In a next
step, you select elements of the depth map and define their depth in shades of grey: in the 3D result,
darker elements appear to be in the background, lighter elements appear to the front.
The greyscale depth map is copied back into @depth, where the information is added to the
respective frame. @depth offers propagation algorithms that intelligently use the annotated depth
map for one frame to create depth maps for all other frames in the same shot. Finally, the result can
be exported into a video format of your choice.
For stereo – i.e. the input has left and right images - @depth provides algorithms to automatically
generate depth information from those stereo images. The resulting depth information quality is
dependent on the quality of the input images. If needed, you can choose to treat this input as 2D and
add your own annotated depth maps; in that case the left image will be chosen is the 2D input. Per
shot you can choose which algorithms – from 2D or stereo – to use.
The following sections describe in detail how to select and annotate frames, automatically process
ranges and shots, and finally export a video / image sequence with depth information.
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Main GUI (Graphical User Interface)
The below illustration shows the GUI of @depth after a project that has been created or loaded:

Within the menu bar of @depth the following commands and menu structure can be distinguished:


Project:
Find here the commands to create New projects, Open existing or Recent projects, to Close
the current project, to change Project Properties. You can start a shot cut detection with the
command Auto-detect Shot Cuts… You also have the option to convert a video into an image
sequence with the command Convert to Image Sequence…;



Edit:
Find here the commands to mark shot cuts and key frames and to start the depth annotation
for the currently selected frame. The menu also offers the option to Copy the Input, the
Annotated Depth, or the Generated Depth – of a frame. With Paste to Annotation, this can
be pasted into another frame where it will appear as Annotated Depth thumbnail.
The Refine Annotation command is only available for annotated frames: it automatically
refines the existing annotation. The Options command gives access to the: Annotation image
editor which lets you choose the image editor that is used for annotating frames. By default,
@depth automatically opens the image editor that on your system is connected to *.png
files.



View:
Find here the commands for customizing the frame preview, for switching on and off the
Layers window.
The View menu also offers the option 3D Preview which becomes available when the PC has
an additional connection to a 3D display. When you choose the option 3D Preview Shows
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Depth, you can toggle between the 3D preview of the video and its corresponding greyscale
depth map by pressing the key D.
For the preview's depth information, @depth uses the Annotated Depth of the frame, if
available. Otherwise, the Generated Depth will be used. If neither is available, the project's
default depth is applied.


Navigation:
Find here the commands for browsing through the frames in the Timeline.



Render:
Find here the commands to start the depth generation for a defined number of frames.
The command ReRender! All starts the Render! Functionality on frames that @depth
interprets as 'up-to-date' and that will therefore not be processed with the normal Render!
commands.



Play:
Find here the commands for playing through the frames in the Timeline.



Window:
Show/Hide the windows you need for the complete workflow: 2D preview properties,
Render status, Shot Settings and Shot Background Settings. An essential window is the Shot
Settings which is used to select what algorithms to use per shot.
See more information about the shot settings on page 34 “Shot Settings”.



Help:
This menu contains the command for the Online Help as well as access to the program's
version information and – with Show Log Folder – to @depth's program logs.

In the upper part of the GUI window you can find the toolbar with buttons for the most important
project-related commands. Underneath you find the Current Frame display, i.e. a preview of the
frame that is highlighted red in the Timeline of the lower part.
The Layers window in the top right enables you to toggle between the different layers of the frame,
i.e. the Input layer, Live Preview Layer, Rendered Output (left/right), the Generated Depth layer and
the Annotated Depth layer. You can also set the transparency of the Live Preview, Generated Depth
layer and the Annotated Depth layer via the % field or the slider. The Layers window opens by
default; you can hide or re-open it via the command 2D Preview Properties in the View menu.
Furthermore, you can customize the Current Frame display by defining the zoom factor, either with
the % field and the corresponding buttons above the preview or by choosing the menu View > Zoom
commands.
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The lower part of the GUI, the Timeline, is your main working area; it contains buttons to process the
input file and add depth to selected frames, and it shows the numbered input frames in
chronological order. Each frame displays a thumbnail of the input image as well as further
information on its status. Thus, you can see at a glance whether the frame is a key frame or a shot
cut and whether a user-created depth map is present.
All relevant commands for working with the Timeline are also available via the context menu.
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Supported input and output formats
@depth supports different image sequence formats and video formats. It is able to use these formats
both as input as for 3D output.
Supported Input formats:
2D or Stereo 3D video:
Movie file
(mpeg, mpg, m1v, mp2, mpa, mpe, ifo, vob,mov)
Windows Media file
(asf, wm, wma, wmv, wmd)
Windows Video files (avi, wmv)
Image Sequence
(bmp, gif, jpeg, jpg, png, tga, tif, tiff, wmp)
3D video:
@depth 3D files

(s3d, b3d)

Supported Output formats:
Windows Media Video (.wmv)
AVI
(.avi)
Image Sequence
(bmp,gif,jpg,png,tif)
@depth 3D image
(b3d), Bitmap (bmp), *.gif, *.jpg, *.png, *.tif (tiff)
Windows Media Photo (wmp), Targa (tga)

Note: .avi and .mov are container formats. Support for the actual contents is depending on the
codecs installed on your machine. You can install extra codecs to support more formats. If you
require any codecs to be supported by @depth, please contact conversions@dimenco.eu.

18

Opening and starting projects
Open a new project
To start a new project in @depth proceeds as follows:
1.

In the menu Project select New to open the input file selection window

Note:
For Stereo Video (side-by-side) note that @depth supports only Left & Right file formats.
For Stereo Video (2 separate files) make sure that the files are synchronized before you
upload them into @depth. @depth is not capable to synchronize.
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2.

Select the file type corresponding to your input file to open the General tab of the New
Project window:

This tab depends on what type of input file you have chosen; in this example, it is the tab for opening
a 2D video file. This is also reflected by the symbol displayed in the lower right corner.
Input file:

Browse for the file that you want to process with @depth. This can be either
a video or the first image of an image sequence.
For stereo videos with two input files, the General tab offers two Input file
fields, the first one asking for the left-input.

Input file contains transparent areas:
@depth supports input videos with an alpha channel. For more information on how
@depth deals with the alpha channel refer to “Alpha Channel Support” on page 43.
Project name:

Enter a name for your project, e.g. ExampleMill for the enclosed sample. This
name will be used for the new project environment that is generated once
you click OK.

Project location:

Browse for and enter the location where you want to generate your new
project environment.
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Frame rate:

For videos, this contains information on the input's frame rate. For an image
sequence, you have to enter a value here, even if you do not plan to export
the image sequence as a video. In that case, the setting will be ignored.

Note:
A red rectangle around one of the text boxes indicates a problem with the input file or the path
setting. You find more information on the specific error in the tooltip if you move the mouse pointer
over the input box:
If your Input file is an image sequence, make sure the filenames contain consecutive numbers as e.g.
Example000001.bmp, Example000002.bmp etc. In the Input file field, enter the name of the file with
which you want the sequence to start; all files with lower numbers will be ignored.
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2.

The Resolution tab for Crop and Resize settings is only available for 2D and 3D input videos,
not for stereo videos. In this tab, you define the working resolution, while the resolution for
the final video / image sequence can be changed again for export:

File Resolution:

This is the native resolution of the original video

Input Resolution:

These are the values with which the input video is opened in @depth. By
default, the Pixel aspect ratio (PAR) is read from the original video if possible.
Otherwise, Square pixels (1.0) is assumed as value. Use the drop-down list to
change these values.

Crop:

With the Crop options you define how many pixels are cut off the sides of
your input video. Custom allows you to crop independently of the aspect
ratio. You can watch the result in the preview thumbnail on the right.

Resize:

With the Resize options, you can change the input video to fit your display.
Default is to leave the video as it is after cropping: Do not resize crop
selection. Clicking Custom offers you the option to define your own
resolution, either with or without keeping the aspect ratio.

Click Default to discard your changes and go back to the default settings.

Note:
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Aspect Ratio: Unchecking the option Keep aspect ratio of Crop selection might result in image
distortion.
Resize: Due to restrictions of Windows Media codecs, the maximum values for the movie output
Width and Height is 4048. The value for Height must be a multiple of 2.
3.

By opening the Advanced tab more setting options are available.

Convert input file to image sequence: With some codecs, frame-exact seeking in video files is not
possible. Therefore, @depth allows converting these videos into a numbered sequence of images. By
default, this option is checked for *.avi, *.mpg, *.mpeg, and *.mov files.
If you uncheck this option and have problems with the frame navigation, you can still convert your
video with the menu Tools > Convert to Image Sequence command.
If your input video has an audio channel which you want to re-use for export make sure that the
input video remains available. The audio channel is not stored in the @depth project environment!
Auto-detect shot cuts: Check this option to let @depth search the input file for shot cuts and mark
them in the Timeline. If you uncheck this option, you can later start this function via the Tools >
Auto-detect Shot Cuts… command.
Default depth: With this value, you define the depth in which objects appear that are not annotated.
The screen depth is not affected by this value. When you process a frame with the Annotate option
in your image editor, the Default depth setting is translated into the correspondent shade of grey. A
changed Default depth can always be restored to the default setting by clicking Default.
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5.

When all settings have been adjusted click OK to continue.

If your input file is a Windows Media file, it needs to be indexed, otherwise @depth cannot start the
project:
Index the original file: Check this option to create the index in your original input file.
Create a working copy and index it: Check this option to make a copy of your input file and have the
copy indexed instead of the original.

6.

Click OK to open the new project. The input file is loaded into @depth's Graphical User
Interface and your project's folder structure is generated in the specified Project location.

Note:
If you want to ensure that moving the project to a different working environment is no problem,
please refer to “Moving the project environment” on page 57 for more information.
Open an existing project
To open an existing @depth project, go to the menu Project, select Open, browse for your file
Project.xsproj and click OK.
Alternatively, you can either choose the project from the Recent list in the Project menu or drag-anddrop the file Project.xsproj into the @depth window.
With the shortcut key Ctrl+R you can load the project that was last opened in @depth.
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Project Folder Structure
@depth automatically generates the following folder structure for each project:
Annotated Depth:

This folder contains those frames that have been annotated, i.e. to
which you have added depth information via an image editor. The
frames are numbered according to the original input frame.

External

This folder appears when the user selects the External depth
algorithm in the Shot Settings window.
For more information about the Shot Settings window and using a 3rd
party program to create/adjust depthmaps see “External Depth” on
page 36.
This folder includes 2 subfolders: Import & Export.
Both folders include 2 folders named foregroundColor and
foregroundDepth.
In the import\foregroundDepth folder the user can copy his manually
created or adjusted depth maps. The export\foregroundColor folder
includes the input files.

Generated Depth:

This folder contains those frames for which depth information has
been created by Rendering. The frames are numbered according to
the original input frames.

Generated Depth Thumbs:

This folder contains thumbnails for the frames' depth maps. The
thumbnails are numbered according to the original input frame.

Input Thumbs:

This folder contains thumbnails for all individual frames of your input
video. The thumbnails are numbered according to their order in the
video

Temp:

This folder is used for working copies of frames. When you click
Annotate to process a frame in your image editor, the frame's image
is opened in an image editor and a copy is placed in this folder.

Frames.data:

This file contains program information on the frames in your video
such as which files are shot cuts and which files are key frames and
contains which algorithms are selected per shot.

Project.xsproj

This is your project file. Choose this file to open an existing project.
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Project Properties
You open the Project Properties window via the command Project > Properties:
General tab: You find information on the Project's name, location, and processing data and on its
Video and Audio properties.

Cropping and Resizing the Input Video
When you crop and resize the input file, there is always the danger of unwanted distortion. If your
result file needs to be in a different resolution, it is advisable to process the input on its original
resolution / size. You can use the crop and resize functionality when exporting the processed file to a
3D format.
An exception to this rule of thumb is when your input file comes with a high resolution and your
output needs to have a low resolution: In such a case you can save time and computing power by
directly loading the input with a lower resolution.
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Timeline
Understanding the timeline

The Timeline is your main working area and provides information about the displayed frames. It
offers you all major commands to process the frames of your video:

When the timeline is colored purple it indicates that those frames are not up-to-date and need to be
updated. When the timeline is colored blue, the frames are up-to-date.

The thumbnail underneath the number corresponds to the input frame.
A greyscale thumbnail in the middle indicates an annotated key frame. In the example, frame 1449 is
an annotated frame.
The second greyscale thumbnail at the bottom indicates the depth that has been generated for the
frame. If no depth has been generated yet, this thumbnail displays the grey that corresponds to your
project's default depth.

The black line indicates the beginning of a new shot, the frame following the black line is a shot cut.
In the example, frame 1442 and 1450 are shot cuts. Shot cuts are also indicated by the shot cut
symbol.
Frames colored in dark blue are key frames. They are frames that need to be annotated. In the
example, frame 1449 and 1454 are both a key frame. Key frames are also indicated by the key frame
symbol.
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The frame with red highlighting is the current frame that is also displayed in the upper part of the
window. In the example, frame 1448 is the current frame.
Stereo videos are indicated by the stereo symbol.
The status bar at the bottom of the window informs you about the chosen, the SMPTE time-code,
and the process status during depth generation.
The buttons above the frames offer you the most important commands for customizing the Timeline,
navigating through the frames as well as preparing and generating depth information. Please refer to
the following chapters for more information on these matters.
Customize the Timeline Display
@depth offers convenient display customization for the chronological display of the frames in the
Timeline.
All:

The Timeline displays all frames of your input file.

Shot Cuts:

The Timeline displays only the shot cuts of your input file.

Key Frames:

The Timeline displays all shot cuts and key frames of your input file.

Every [Number]: The Timeline displays all shot cuts and key frames as well as normal frames in the
defined interval as e.g. every tenth frame. The minimum number for the interval is 2
Timeline Navigation
@depth comes with standard navigation buttons to easily browse through the frames in the
Timeline.
Click

to go to the first frame.

Click

to go to the first frame of a page's display.

Click
to jump back one frame.
In the [Number] field, specify the number of the frame you want to go to and then press Enter.
Click

to jump forward one frame.

Click this
Click

to go to the last frame of a page's display.

to go to the last frame.

Alternatively to clicking the buttons, you can choose the commands from the Navigation menu or
use the shortcuts.
Note:
Navigation Speed: Unchecking the previews Annotated Depth, Generated Depth, and Input in the
Layers window significantly increases the navigation speed in the Timeline.

Shot Cuts, Key Frames, and Annotation
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Toolbar for annotation tasks

@depth offers a number of command buttons that make it easy to select and prepare individual
frames for the depth generation.
Click the
Annotate button to start the annotation of the selected frame in an image editor such as
Photoshop or Paint.
Click the
button, to refine the current frame's existing annotation. This command is only available
for annotated frames.
Click the
marker.

button to mark the currently selected frame as shot cut. Clicking again removes the

Click the
marker.

button to mark the currently selected frame as key frame. Clicking again removes the

Click the
button to copy the frame's Annotated Depth to the clipboard. To copy the frame's Input
or Generated Depth uses the respective commands from the Edit menu or from the right-click menu.
Click the

button to get the depth information from the clipboard and paste it to the annotation of

the selected frame. Paste actions can be undone and redone with the
Click the

and

buttons.

to change the individual shot's settings used for the Render! functionality.

Alternatively to clicking the buttons, you can choose the commands from the Edit and Shot menus or
use the shortcuts.
Shot Cuts and Key Frames
When a video is loaded into @depth, the program automatically checks for and marks shot cuts. You
can revise the automatic selection, mark your own shot cuts and key frames, and start adding depth
information.
Shot Cuts
define the beginning of a decisive frame sequence i.e. the beginning of a new shot.
@depth offers you an automatic search for shot cuts with the menu Tools > Auto-detect Shot Cuts
command.
Key Frames
are those frames in a frame sequence to which depth information is added in the
annotation process. Starting from an annotated key frame, @depth's Render! functionality
automatically generates depth information for the preceding and following frames in a range or shot.

@depth offers convenient options for marking frames as shot cuts or key frames:


To mark a frame as shot cut, select the frame and then click the Mark as Shot Cut

button.
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To mark a frame as key frame, select the frame and then click the Mark as Key Frame
button.
A frame also becomes a key frame when you double-click on it to Annotate: even if you do not
complete the annotation, the frame keeps its dark blue color.
To remove the marker, just click the corresponding button again.
Alternatively, you can choose the corresponding commands from the right-click menu or use the
shortcuts.

Note:
In shots where no propagation algorithms are used (auto from 2D or stereo), no keyframes are
needed.
Key frame selection tips
Theoretically, you can select any frame in a range or shot, annotate it and use the Render!
functionality to generate depth for the whole range/shot. However, we advise the following when
choosing key frames:
-

If your shot/range contains objects that come into and fade out of view, it is advisable to
choose as key frame a frame in which objects are best visible. This enables you to annotate
with much more detail.

-

In a shot/range with only little changes, choose a key frame from the middle. Depth
generation starts at the key frame, generates depth for the frames following it and then
starts again to generate depth for the preceding frames. Thus, it only has to cover about half
the number of frames in each direction – compared to generating depth for the complete
shot/range in one direction only. The advantage is that with fewer frames to cover, the
Render! functionality remains more precise.

Annotate a frame
1.

In the Timeline, double-click the frame you want to annotate.
Alternatively, you can use the
menu, or use the shortcut.

2.

Annotate button, choose the option from the right-click

An image editor opens on a working copy of the current frame. A working copy of this image
is stored in the Temp folder of your project environment.
Simultaneously, @depth puts a default depth map – i.e. a grey rectangle in the size of your
working resolution – on the clipboard. The depth map's grey shade reflects the project's
default depth as defined in the Advanced tab upon opening the project.

3.

In the image editor, open a new layer and paste the depth map from the clipboard into it.

4.

Select areas of the image and in the depth map layer, and define their depth in shades of
grey – the lighter an area the more it moves to the foreground in a 3D video.
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5.

Copy the completed depth map layer, go back to @depth, and click the Paste button. In
the middle of the annotated frame you now see a greyscale thumbnail representing the
Annotated Depth.

Note:
By default, the image editor that is associated with the file extension *.jpg or *.png is used for
annotation. Change this preference by going to the Tools menu, selecting Options and then choosing
the desired image editor from the drop-down list.
Annotate with Copy & Paste commands
It is also possible to use the Annotated Depth of a key frame for other frames.
1.

Select the key frame with the Annotated Depth. The Copy

button becomes active.

2.

Click the Copy
button and then select the frame to which you want to add the copied
Annotated Depth.

3.

Click the Paste to Annotation
button to add the Annotated Depth. It now appears as
middle thumbnail and the frame is marked as key frame.

If you want to use the input frame or the frames generated depth for annotation, you can also copy
these. Just choose the Copy command from either the Edit menu or the right-click menu. Here, you
will find the alternatives Copy > Input and Copy > Generated Depth.

Revise Annotated Depth
The Annotated Depth of a frame can be revised as follows:
1.

Double-click the annotated key frame; an image editor opens and the current Annotated
Depth map is placed on the clipboard.

2.

Paste the current Annotated Depth map from the clipboard into a new layer in your image
editor.

3.

Change the depth map according to your needs, copy it and paste it back into @depth.

4.

The new Annotated Depth is now displayed in the key frame and can be applied for depth
generation.
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Deactivate Annotated Depth
To deactivate an Annotated Depth from a key frame, you have to remove the key frame marker:
1.

Click the annotated key frame.

2.

Click the
button. The frame changes into a normal frame and the Annotated Depth is no
longer displayed.

Even if the Annotated Depth is deactivated, its information is stored in the project environment. It
can be easily restored by marking the frame as Key Frame again.
Generated Depth as basis for annotation
The Generated Depth in a non-annotated frame can be used as Annotated Depth:
1.

Click the frame with the Generated Depth.

2.

Click the Mark as Key Frame button. The frame now has a Generated Depth as well as an
Annotated Depth that is identical to the Generated Depth.

3.

To revise this Annotated Depth, double-click the frame, paste the Annotated Depth from the
clipboard into a new layer in the image editor and change it according to your needs.

If you want to use the Generated Depth of one frame as Annotated Depth in another frame you can
easily do this by using the Copy & Paste commands:
1.

Click the frame with the desired Generated Depth.

2.

From the Edit menu, choose Copy > Generated Depth.

3.

Click the frame to which you want to copy the depth information and then click the Paste to
Annotation

4.

button. The frame now has an Annotated Depth thumbnail.

To revise this Annotated Depth, double-click the frame, paste the Annotated Depth from the
clipboard into a new layer in the image editor and change it according to your needs.

Use the Refine Annotation command
The Refine Annotation command is only available for annotated frames and aims at improving the
existing annotation. It is especially useful to carve out more details in a roughly annotated frame.
1.

Select any annotated frame you want to refine.

2.

Click the
button to let @depth automatically improve the annotation; the annotation is
adjusted to the original image and the depth map becomes more detailed. To observe the
change in the Current Frame display, check Annotated Depth in the Layers window and
adjust the percentage.
Alternatively to clicking the button, you can also choose the command from the Edit menu or
from the right-click menu.
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3.

Repeat the Refine Annotation command until you are satisfied with the result. You can also
undo the last Refine Annotation command by clicking the button.

Render! Functionality
In 2D videos, the Render! button starts the automatic process of adding depth information to frames
following or preceding an annotated key frame in the same shot. If no keyframes are present
@depth offers a few automatic algorithms to generate depth from 2D.
If the project contains stereo data, the choice is extended with automatic depth calculating
algorithms from stereo footage.
Click Render! Shot on the toolbar to generate depth information for a shot, i.e. for all frames
between two shot cuts.
Cancel is only available while the depth generation is in progress. Click Cancel to stop the depth
generation. This does not affect the frames already processed!

While the Render! command is executed you can follow its progress by choosing Render! Status
from the View menu.
Depending on the size of your working window, the Render! Shot and Cancel buttons might be
hidden and can be made visible by clicking the small black arrow in the right bottom corner
Alternatively to the buttons, you can start the Render! functionality via the Render! commands in
the main or right-click menu. Here, you also find the Render! All command with which you cover the
complete video. Thus, you can check before exporting the file whether all shots and ranges are
processed and no key frames without annotation remain.
If the frames you want to process are up-to-date – i.e. no change to annotation, project properties or
Shot Settings has occurred since the last Render! process – a message box informs you about this
fact. You have then the option to go on with the Render! process or to cancel it.
The command ReRender! all from the Render! menu starts the Render! process without checking
the up-to-date status of the frames.
Note:
To use algorithms such as propagate accurate, fast and copy, @depth expects you to annotate key
frames before using the Render! functionality. If you try to generate depth with a non-annotated key
frame in the range or shot you will receive an error message and the depth generation cannot start.
For stereo videos, depth generation is possible without annotating key frames. However, if you have
marked one of the propagation algorithms in a shot (see below), the key frames in these shots need
to be annotated as well.
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Shot Settings
Depending on your specific video you might have to change the Shot Settings for individual shots to
receive a better result. By default the Shot Settings window is already visible. It’s title bar shows the
starting and stopping frame of the currently selected shot. If you want to select another shot or if
the window is not visible, proceed as follows:
1.

Select a frame on the timeline of the shot for which you want to change the Shot Settings

2.

Click the
button or select the command Shot Settings from the Window menu or from the
right-click menu.

3.

Check the algorithm(s) in the Shot settings window according to your needs (see below)

For each shot different settings can be applied for depth generation process that is started with the
Render! Command.
Every shot starts with a default settings that can be customized. When you create two shots by
dividing a shot with a shot cut, the shot starting with the new shot cut will start with the same
properties as the original shot.
The following screenshots shows the Shot Settings window working from a Stereo project (left
image)and from a 2D project (right image)

Note:
A purple border will appear around the setting, this indicates that the shot needs to be updated by
clicking on the Update Render button.
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2D Auto Gravity, Motion and Slant
These algorithms are used for automatic depth generation from 2D. To realize the best quality from
2D we recommend working from annotations, however, these automatic algorithms do provide the
user a good understanding of the content and challenges within the conversion of content.
2D Auto Gravity:

Use this mode if you don’t want to make annotations. Processing time is less
than 1 seconds/frame.

2D Auto Motion:

Use this mode if you don’t want to make annotations. 2D auto Motion
calculates depth from the amount of motion within the scene.
Processing time is less than 1 seconds/frame.

2D Auto Slant:

This mode uses a smart gradient for depth calculation.
Processing time is less than 1 seconds/frame

2D Propagate Fast and Copy
These algorithms are used for depth generation based on annotated key frames. These annotated
frames have to be manually created.
2D Propagate Fast:

We recommend using this algorithm for a quick preview. The result is also
satisfactory for simple scenes with large objects, scenes with fast moving
objects and scenes with strong color contrast between foreground and
background. Processing time is less than 1 second/frame.

Full Resolution:

This option is checked by default. This option can be changed in the
Algorithm settings window. Click on Settings and check Full Resolution
This mode is recommended for scenes with fine detailed static structures, as
e.g. a wire-mesh fence, or text. Scenes with strong color contrast between
foreground and background will also show a good result. Processing time is
less than 1 seconds/frame.

Two passes:

This option is checked by default. Uncheck this to disable the depth
generation in both directions in a shot or range with more than one
annotated key frame. Refer to “Process direction in Render! functionality” on
page 41 for more information on two-pass. We recommend keeping this
option checked.

2D Propagate Copy:

Using this algorithm, the depth map is not calculated for each frame
individually but merely copied without changes from the annotated frame to
the other frames of the shot. Furthermore, if used with Use two-pass and
two annotated frames in one shot, the feature also makes sure that the two
annotations are blended into each other. Working with the Copy mode is
especially useful e.g. for text or logos.
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Stereo Fast/Detailed
These algorithms are only available for projects that have stereo information, i.e. left and right
images.
Stereo Fast:

Use this mode for quick results and for a general overview; processing time is
less than 1 second/frame.

Stereo Detailed:

Use this mode for better quality; processing time is less than 2
seconds/frame.

Temporal Smoothness: Filters the depth in time. The higher, the slower the change in depth.
Spatial Smoothness:

Filters the depth within one frame. The higher, the more smooth the depth
will be. Use this when the depth is fluctuating too much within small regions.

External Depth
This option is checked when the user wants to use manually created e.g. adjusted depth maps.
Usually the user first ‘Render!’s depth maps using the other algorithms. In case @depth cannot
provide the desired quality in that way, the user can select the ‘External Depth’ algorithm, which will
disable (gray out) all the other algorithms.
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When the user clicks on Copy in the Shot Settings window , a folder external will be created within
the project folder.

The external folder includes 2 subfolders, export and import. Upon clicking the Copy button @depth
will copy the 2D input images as well as the Generated Depth – output of the last Render! action - to
the subfolders of the external\export folder.
You can now start adapting these images using external tools, for instance Adobe AfterEffects. After
adapting, please save the adapted images in the respective subfolders of the external\import folder.
Note: depthmaps need to be a .png image sequence starting with the 4 letter string “depth” followed
up by a 6 digit number corresponding to the original input file. For every frame in the shot there
should be a depthmap present, else ‘Render!’ will fail.
Example: depth000000.png
Upon ‘Update Render’ @depth will copy the foregroundDepth images in the import folder for every
frame and use it as the Generated Depth.
Preview Combined
This is not an algorithm that can be checked. However, when this item is selected in the list, the live
preview will show the combination of all selected plugins combined according to their weights.
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Global Settings
Amount of Parallax
Move the slider to change the amount of depth. When connected, you can live-preview the result
on your 3D stereo TV. For Live preview settings see “Live-Preview Options” on page 45.
Parallax Offset
Move the slider to change the amount of Offset. When connected, you can live-preview the result on
your 3D stereo TV. For Live preview settings see “Live-Preview Options” on page 45.
Copying/Pasting Shot Settings

Shot settings can be copied and pasted to each other by Right Mouse Click on a frame on the
timeline.
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Parallax Histogram
To change the parallax settings per algorithm per shot, click the Settings button for an algorithm in
the Shot Settings window.
Parallax adjustment: The histogram represents how objects are distributed from the background to
the foreground of the current shot; it also shows the depth range.

Red curve: The curve controls how disparity is mapped to depth. The steeper the curve, the more
depth detail is generated for this area. In general, the curve calculated by default offers satisfying
results. However, the ideal curve always depends on your individual video material and the effect
that you want to achieve.
Blue bars: The blue bars to the left and right mark the shot's disparity range; in this range, @depth
will search for objects to calculate their depth. The gap between the blue histogram and the Near
blue bar helps to avoid so-called window violations: objects at the side of the screen should not be
put at a depth that moves them to the very front. If necessary, you can reduce this gap for shots in
which window violation is no issue
Small blue marks: The small blue marks on the horizontal line of the histogram indicate the original
Disparity range as it was calculated by @depth during the first depth generation process. After the
first Render! process, their position is identical to the blue bars.
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Small red marks: The small red marks on the depth scale show the depth values of the beginning and
end of the red curve.
The preview image underneath the histogram shows the effects of your changes on the depth map.
Blue marks the elements that are ignored in the Far area; Red marks the elements that are ignored in
the Near area.
Note: when the current algorithm is selected – shows up highlighted in the algorithm list of the Shot
Settings - the preview is not shown in this window, but in the bigger main 2D preview window.
Drag the red handles to change the red curve; move the mouse over the blue bars, drag them to
change the Disparity range. These changes will be reflected in the Live Preview Layer.
Click OK and then use the Render! Functionality once again for the customized shot. The Generated
Depth changes according to the settings performed in the histogram.
Check the result and if necessary perform more changes on the parameters for the depth generation.
For mono-colored frames, the shot properties do not behave as described. It might be the case that
changing the disparity range and the red curve is not possible.
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Process direction in Render! functionality
When you click the Render! button or choose this functionality from the menu, @depth begins to
add depth information to the frames in the current shot, or all frames of your input file.
In the depth generation process for propagation algorithms, @depth by default first attempts to
generate depth by starting on a key frame and proceeding to its right (i.e. to the following frames). If
this is not possible, the preceding frames are processed i.e. the depth generation is executed from
right-to-left.
For processing a complete shot with several ranges, @depth starts with the shot's first range and
then consecutively proceeds to the next. This is independent from the frame that is selected when
the functionality is started.
Consider the following examples:

Select a frame between 0 and 36 and click Render! Shot. @depth always renders the whole shot with
all annotated key frames in it. In this case frames 10 and 20 are annotations.
Note: the more annotated key frames, the better the quality
The processing of the area between the two key frames 10 and 20 depends on your setting of the
option Use two-pass in the Settings of the Shot Settings window (Project menu > Shot Settings…).
By default, Use two-pass is set:
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Select any frame between 0 and 35 and click Render! Shot:
@depth will now start 4 jobs for this shot, of which the first 3 can be processed in parallel:
1.
2.
3.
4.

add depth to the frames 10 to 0.
add depth to the frames 10 to 19, first forward, and then backward using keyframe 20.
add depth to the frames 20 to 35.
Finally, @depth combines multiple algorithms and uses the manually changed parallax
settings per algorithm to calculate the Generated Depth for this entire shot.

In contrast to this, double-processing of a range bordered by two annotated key frames is disabled
when you uncheck the option Use two-pass: In a range in which depth can be generated from two
bordering key frames only the depth generation is executed that follows the left-to-right direction:

Note:
Use two-pass: We strongly advise to keep this option active. Using it has two major advantages:
1.

The option helps to reduce quality gaps between ranges. The single-pass Render! process in
the above example results in a newly computed depth for each range, i.e. frame 20 starts
with a depth that is only connected to your annotation and to the generated depth in frame
19. With two-pass, this is avoided because depth generation is performed from frame 20
backwards to frame 10, thus closing the gap between 19 and 20. The resulting generated
depth is more precise than without using two-pass.

2.

As a direct consequence of 1, single-pass is not able to cope with objects that move from the
foreground to the back or vice versa. Such a movement over several ranges in a shot can only
be represented smoothly when using two-pass. In such a shot, its best practice to add
annotated key frames where the moving object is the farthest away and where it is nearest.
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Alpha Channel Support
@depth enables you to use files with alpha channel information as input. @depth treats the alpha
channel information – i.e. the color that is defined to be transparent – as a fourth color besides Red,
Green, and Blue. As such it is used during depth generation.
When you export a video with transparency information it depends on the selected export format
whether the transparency information continues to be available after export:
Case 1: Your export format does not support alpha – as e.g. WMV or BMP
If you export to a format that does not support transparency, the transparent areas by default are
overlaid on a black background. For the overlaying – also called alpha-blending – the Advanced tab of
the Export dialog offers you the option to change the fill color: via Fill transparent areas with, you can
either enter specific RGB values or select a color from the color palette.
Case 2: Your export format supports alpha – as e.g. AVI or PNG
When you choose an export format that supports transparency, the information about transparent
areas is also available in the exported video.
However, for reasons of further processing you might want to fill the transparent areas; this is
possible with the respective option in the Advanced tab of the Export dialog. If you select this option,
transparent areas are filled with the specified color and the exported file no longer contains
transparency information.
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3D Player
@depth offers you a video player functionality that is available if you have an additional 3D display
connected to your PC. You also need to check the option 3D Preview in the View menu.
To start the player, go to the Tools menu and choose the command
Play Shot to play the current shot with the latest generated depth. If there is only one shot for the
whole video, the whole video will be played.
Play All to play the video.
All commands open this player:

Use the player buttons and slider to customize the viewing. The slider's default position corresponds
to the input frame rate. However, the frame rate that is actually achieved by the player depends on
your system and might differ from the input frame rate.
If not paused or stopped, the range, shot, or video is continuously replayed.
Alternatively to starting the player via the menu Tools you can also click the Play Shot buttons
situated above the Current Frame display.
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Live-Preview Options
@depth provides the possibility to preview your conversion on a 3D stereo (3D with glasses) and/or a
3D auto-stereoscopic (3D without glasses) display. To realize the best result we also recommend
using one or both of such displays to evaluate the result.
Stereo preview
To preview the stereo result of the conversion or editing the software is able to send L+R data to the
stereoscopic display.

Stereo SBS preview (on Stereo 3D TV/Monitor)

To preview the Left and Right result on the 2D display you can check the Left or Right view in the
Layers window.

Note:
The shot must be Rendered first in order to preview the left or right image. When connected, you
can also display your @depth project on the 3D Stereo TV via view  3D preview
Be sure to put your 3D stereo TV in 3D mode and set the viewing method to Side-by-Side.
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Auto-stereoscopic preview
To preview the auto-stereo result of the conversion a 2Dimage + depth map is send to the display. If
the display requires multiple views as input, a separate rendering of these views is necessary. This is
currently not possible in @depth. @depth supports Dimenco and Philips 3D auto-stereoscopic
displays.

2D+Z-depth input to preview auto-stereoscopic 3D
Preview Settings
To view the 3d preview settings window go to: View  3D Preview Settings
3D Preview Settings allows you to change the depth (parallax) factor and offset of the stereo output.
This is both used in the preview and export functionality.
Depth edge filtering: increases or decreases the edges of an object in the depth-map.
Output: allows you to swap the left and right image.

Click on Apply to see the result. These settings are also used when exporting the file.
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Export the 3D video file
After completing your conversion the result can be exported to a 3D video or image sequence.
Export to 3D video

1.

Click

to open the Export window.

2.

Adjust the settings in the General tab:

Image Format: Select 2D+Z or Stereo. When you select Stereo, an extra tab with stereo settings
appears.
File Format:

Select Windows Media Video or AVI for exporting a video file. To export an image
sequence we refer you to page 54.

Output Location: Specify where the output file is to be stored. By default, your project environment
is used.
Export Range: With these options you can define the frames for export. You can either export All
frames or select a frame range. For the second option, you specify the first and the
last frame number of the range. This is especially useful if you want to check the
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depth generation result of a single shot/range without having to wait for the export
of the whole video.
3.

Adjust the settings in the Resolution tab:

Working Resolution:

Find here the resolution of your video.

Crop: With the Crop options you define how many pixels are cut off the sides of your input video.
With the option Use aspect ratio, the specified aspect ratio determines what can be cut off. The
slider offers you to move between the extremes of cutting off information – Crop – and of adjusting
the complete information and thus risking Black Bars. Check the result in the preview on the right:
your selection is the image in the red rectangle.
If you select Custom, you can crop the input without taking care of a specific aspect ratio. For both
options, you can watch the result in the preview thumbnail on the right.
With the Resize options you can change the cropped video / image to fit a specific display:
Do not resize crop selection: the file is exported in its current size.
960 x 540 pixels (16:9): Use this option to match the export file to a 42'' display. This is the default
setting.
800 x 600 pixels (4:3): Use this option to match the export file to a 20'' display
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Custom: Use this option to customize the video / image size to your own environment. Check Keep
aspect ratio of crop selection to avoid distortion.
Default: Click this button to restore the default Crop and Resize settings.

Note:
Crop: Negative values for Top, Bottom, Left, or Right indicate that the display of the video/image will
contain black bars on that side.
Aspect Ratio: Defining different aspect ratio values for Crop and Resize could result in image
distortion.
Resize: The AVI and image sequence maximum values are for Width 1920 and for Height 1080.
The WMV maximum values are for Width 1920 and for Height 1024.
The value for Height must be a multiple of 2.
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4.

Adjust the settings in the Advanced tab:

Video:
Fill transparent areas with: Use this option if you want to further process the video with another
tool. The option sets the alpha channel value.
Export into separate files: By default, @depth exports your composition into one single file. This file
contains the following information for each frame of your video:
2D+Z:



Foreground color: the color image
Foreground depth: the depth map for the color image
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3D Stereo:



Left: the left-eye image
Right: the right-eye image

When exporting to stereo, the option Export into separate files is available to export the left and
right images individually. You find the resulting files in the folder specified in the General tab. The
filenames reflect which information is stored:
[OutputName]_left and
[OutputName]_right respectively.
Specify the Codec you want to use for the export process. Codec availability depends on your specific
system installation. For AVI output not all codecs work correctly with @depth. We have tested the
following codecs:




Uncompressed
Lagarith Lossless Codec
Xvid MPEG-4 Codec (be sure to disable displaying of encoding stats in its configuration using
the Configure button and then ‘Other Options…’)

In addition, for Windows Media output you can define the Quality of the export result. With reduced
quality, the export speed is increased.
Audio: If an audio channel is available, it can be included in the export file by checking Export with
audio. Additionally, audio Codec and Quality can be defined here. With reduced quality, the export
speed is increased.
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5.

For stereo output, adjust the settings in the Stereo tab:

Depth factor: Increase/Decrease the amount of depth.
Depth offset: Specify which grey-level (0-255) in the depth map is at screen depth.
Depth edge filtering: Filter the depth map to make errors in the depth map less visible.
Concatenate images: The left and right generated images are stitched without resizing.
Squeeze images: The left and right generated imaged are resized to half width and then stitched.
Swap left and right: Normally the left-eye image is put on the left. When selected, the right-eye
image is on the left.

6.

Click OK to start the export. Depending on the size of your project this might take some time.
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Note:
Export to AVI
When exporting to AVI please consider the following:
1.

High resolution video material is not supported by most media players in real time. The
resulting video playback could be too slow and no longer synchronous with the audio
channel. Furthermore, video frames could be dropped.
For these reasons, export to AVI using lossless or uncompressed codec should only be chosen
if further processing of the material is intended, not for playback.

2.

Input material that contains more than two audio channels or which has more than 16bits
per sample will be formatted to stereo and 16 bits per sample when exporting to AVI.

3.

When you export a video into AVI with the Lagarith lossless codec, exporting the alpha
channel is disabled by default. To enable it, press the Configure button in the Export dialog
and select RGBA from the Mode list. Also Multithreading seems to be disabled by default.
In the Export dialog also make sure that the option Enable Null Frames is disabled.
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Export to image sequence

1.

Click

to open the Export window.

Select “Image Sequence” in the File Format.
Adjust any nessecary options in the Advanced tab.

Image Format: Select 2D+Z or Stereo. When you select Stereo, an extra tab with stereo settings
appears.
File Format:

Select here Image Sequence to make the other options visible.

Output Location: Specify where the output file is to be stored. By default, your project environment
is used.
Sequence Name: Specify the name of the output sequence. With this name, all exported image file
names will start.
Start Frame:

Specify the frame with which the export sequence starts. If you want to check the
depth generation result of a single shot/range only, you do not have to export the
whole image sequence.

Type:

Specify the image type. By default, @depth offers the .b3d file format. This is
automatically opened by the 3D player.
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@depth offers various other image formats that can be chosen. Opening these will
display the original image side by side with a greyscale depth map.
Example:

The example shows you how the file names in the resulting image sequence are
composed; the file number created by @depth is added to the newly specified
Sequence Name.

Export Range: You have the choice of exporting either the whole image sequence or a specified
number of frames.
3.

Adjust the settings in the Resolution tab as described in Step 3 for the video export.

4.

If your image sequence contains transparent areas, the Advanced tab is available for
adjustments:

Fill transparent areas with: Use this option if you want to further process the video with
another tool. The option sets the alpha channel value.
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5.

When Stereo is selected as Image Format, you can specify how the left and right images are
generated:

Depth factor: Increase/Decrease depth.
Depth offset: Specify which grey-level (0-255) in the depth map is at screen depth.
Depth edge filtering: Filter the depth map to make errors in the depth map less visible.
Concatenate images: The left and right generated images are stitched without resizing.
Squeeze images: The left and right generated imaged are resized to half width and then
stitched.
Swap left and right: Normally the left-eye image is put on the left. When selected, the righteye image is on the left.

6.

Click OK to start the export. Depending on the size of your project, this might take some
time.
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Moving the project environment
In general, there is no problem in moving the @depth project to a new environment. However, make
sure that the required codecs are installed in the new environment and that the input video file
remains available to @depth on the same relative path or the exactly identical absolute path
(including the drive letter).
If you expect to move projects between environments and workstations, we advise to follow
@depth's rule for the relative path to avoid any problems with input files: make sure that the input
files are;
either on the same directory level as the actual project folder or
in a directory path that is parallel to the project folder.
Consider the following examples:
You start your Project in your own document environment and place a video file on the same level.
The project and input video have to be moved together to the new environment and be placed on
the same level again:

In the second example you have a separate input file environment parallel to your project folder, e.g.
if you are working with an image sequence. In this case, you have to move the complete input file
environment together with the project folder:
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Troubleshooting
Problem

Possible Reason/Solution

Seeking through the Timeline
does not function properly, e.g.
the currently selected frame and
the preview are not matching.

If the format of your input file is *.avi, *.mpeg, *.mpg, or
*.mov, there might be problems with the navigation in the
Timeline. It is therefore suggested upon loading to Convert
input file to image sequence (Project > New… > Advanced
tab).
If you uncheck this option when starting the project, you can
later choose the command Convert to Image Sequence…
from the Tools menu.

The VC 100 runtime installation
failed.

Manually re-install the VC 100 runtime; you find the
appropriate file on your installation package.

The VC 100 runtime installer
always show to repair.

Usually the runtime is correctly installed despite this
message. Please run AdepthSetup.msi directly if Setup.exe
doesn’t proceed with installing @depth

@depth crashes when I load an
aes-encrypted avi file.

@depth cannot play aes-encrypted avi files.

My video has an audio stream
but it does not show in @depth.

When an audio stream cannot be read, the video is loaded
and appears as having no audio stream.
For videos with AC3 audio (Dolby Digital 5.1), install the a3c
filter from http://ac3filter.net.

I have problems exporting a
video with an audio stream.

If you experience problems when exporting a media file with
audio, a potential cause is that the file contains multiple
audio streams. You can solve this problem by installing a
Direct Show filter that allows switching between audio
streams, such as the freeware program Morgan Stream
Switcher.
http://www.morgan-multimedia.com/mmswitch/index.htm
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The Export function does not
work properly.

If @depth has problems with your video's specific audio
constellation, it might happen that Export does not function.
In such a case, uncheck the option Use audio channel in the
Export window's Advanced tab.

I cannot export a range of
frames for my mpeg video;
exporting the whole video,
however, is no problem.

For mpeg files with an audio channel, it is not possible to
export a selected range of frames. For exporting a range, you
have to uncheck the option Use audio channel in the Export
window's Advanced tab. and export the range without the
audio information.

The 3D Preview function does
not work even though I have a
3D display.

When using a Philips 3D display, the 3D Preview function
only works with a Display Firmware Version of 1.0 B7 or
above.

Drag-and-dropping the project
file to open @depth does not
work.

Make sure that no files in your project folder are read-only.

Handling files that are no longer
open in @depth is impeded.

Close and then restart @depth to release these files.

There are memory problems
when working with WMV files.

This is a known problem with WMV files and readers. Instead
of closing and opening projects you should from time to time
close and open @depth.

WMV movies with WMV9
Advanced Profile codec do not
play.

Check whether the Windows Media Player 11 or later is
installed.

My mpeg codec does not work
properly with @depth

It is a known issue that some mpeg codecs do not work with
@depth. One solution is to use the Elecard decoder from
www.elecard.com.

If you intend to support older player versions, we
recommend to use WMV9 and WMA9.2 during encoding.

When working parallel with MS Such a behavior of the Office clipboard is a known issue. A
Office and @depth's Annotate
solution is to close MS Office – and thus to close the Office
function, I get the message
clipboard.
"Collected Format is not
supported by Office clipboard".
The picture then opens correctly
in my image editor and I can
annotate it. However, pasting it
back to @depth does not work.
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I use Photoshop and have
problems with copy/paste for
the Annotate function: the
depth map changes with the
copy/paste process. It becomes
lighter/darker.

The reason for this behavior is Photoshop's internal color
profiles. A solution is to choose the command Color
Settings… from the menu Edit. In the Color Settings window,
select North America Web/Internet from the Settings list.

I am working with Windows
The standard installation of Windows Vista contains version
Vista and have problems running 10 of DirectX, the @depth software, however, also needs an
the @depth setup – the
installation of DirectX version 9. To solve the problem:
installation of DirectX crashes.
1. Go
to
the
Microsoft
Download
http://www.microsoft.com/downloads.

Center

site

2. Get the latest DirectX version. This will install the latest
version as well as the previous ones i.e. version 9 will be
available, too.
3. Finally, restart the @depth setup.
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List of Shortcuts
Shortcut

Functionality

Ctrl + N

New project

Ctrl + O

Open existing project

Ctrl + R

Open most recent project

Ctrl + F4

Close project, leave @depth open

Ctrl + E

Start 3D export

Ctrl + Shift + P

Project properties

Ctrl + T

Annotate

Ctrl + F

Refine annotation

Ctrl + Shift + S

Mark as shot cut

Ctrl + Shift + K

Mark as key frame

Ctrl + Z

Undo paste

Ctrl + Y

Redo paste

Ctrl + Alt + C

Copy input

Ctrl + C

Copy annotated depth

Ctrl + Shift + C

Copy generated depth

Ctrl + V

Paste

Ctrl + +

Zoom in frame view

Ctrl + -

Zoom out frame view

Ctrl + Shift + W

Zoom to window size

Ctrl + Shift + A

Zoom to original size (100%)

D

In 3D preview: toggle between depth map and
image.
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Ctrl + P

Shot properties

Home

First frame

Page Up

Previous frame page in Timeline

Left

Previous frame

Right

Next frame

Page Down

Next frame page in Timeline

End

Last frame

Ctrl + G

Go to frame

F5

Render! range

Ctrl + F5

Render! shot

Alt + F5

Render! all

Alt + Shift + F5

ReRender! all

Esc

Interrupt and cancel Render! process

F6

Play range

Ctrl + F6

Play shot

Alt + F6

Play all

F1

Online help
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